Счетчик

Поисковый анализ сайта
яндекс.ћетрика
Cервер и сайт запущен 2011.02.01 на Debian

Переустановка php5

Удаляем имеющийся php:

apt-get remove php5-common php5 libapache2-mod-php5 php5-cli php5-cgi php5-mysql

На всякий случай посмотрим может что осталось, и удалим:

apt-get autoremove

Очистим кэш испманагера: /usr/local/ispmgr/sbin/pkgctl cache

Что бы он понимал что происходит

И устанавливаем:

apt-get install php5-cgi php5-cli libapache2-mod-php5

Все бы ничего. Но при php -v у меня писало типа: PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib/php5/20060613+lfs/gd.so’ — /usr/lib/php5/20060613+lfs/gd.so: cannot open shared object file: No such file or directory in Unknown on line 0

Остались расширения от предыдущего php.

Я просто заново установил расширения, на которые была ругань:

apt-get install php5-mysql apt-get install php5-gd

И получил в ответ:

 # php -v  PHP 5.2.6-1+lenny16 with Suhosin-Patch 0.9.6.2 (cli) (built: Feb 3 2012 13:17:21)  Copyright (c) 1997-2008 The PHP Group  Zend Engine v2.2.0, Copyright (c) 1998-2008 Zend Technologies

Добавить комментарий


Защитный код
Обновить